Power Outage - Hendrick Chevrolet Cadillac
Incident Report for Hendrick Automotive Group
Resolved
Power has been restored and network connectivity stable as of 10:26 pm last night at Hendrick Chevrolet Cadillac.
Posted Jan 13, 2024 - 07:17 EST
Investigating
Hendrick Chevrolet Cadillac is experiencing a power outage which is impacting network connectivity and building operations. We will provide an update as more information becomes available.
Posted Jan 12, 2024 - 18:44 EST
This incident affected: Building Operations.