Power Outage - Multiple Dealerships in Charlotte, NC

Incident Report for Hendrick Automotive Group

Resolved

Power has been restored at all of the impacted locations.
Posted Apr 11, 2025 - 23:18 EDT

Investigating

The following locations are experiencing a localized power outage. We will provide updates as more information becomes available.

Impacted Locations:

Hendrick Acura
Jaguar Land Rover Charlotte
Hendrick BMW
Hendrick Porsche
Hendrick Mini
Posted Apr 11, 2025 - 20:56 EDT
This incident affected: Building Operations.