Power Outage - Hendrick Collision Center of Rock Hill
Incident Report for Hendrick Automotive Group
Resolved
Power has been restored at Hendrick Collision Center of Rock Hill. All systems are functioning normally.
Posted Oct 03, 2024 - 18:11 EDT
Investigating
Hendrick Collision Center of Rock Hill is experiencing a power outage, due to a transformer issue in the area. Repairs are underway and are expected to be completed by 8PM ET. We will provide updates as more information becomes available.
Posted Oct 03, 2024 - 16:32 EDT
This incident affected: Building Operations.