Power Outage - Multiple Dealerships in Kansas

Incident Report for Hendrick Automotive Group

Resolved

This incident has been resolved.
Posted Jul 09, 2026 - 13:14 EDT

Investigating

Network connectivity at the following locations is impacted due to power issues impacting the local area. We will provide an update as more information becomes available.

Impacted Locations:
Kansas City Business Office
Hendrick Lexus Kansas City
Posted Jul 09, 2026 - 07:52 EDT
This incident affected: Building Operations.