Partial Network Outage - Hendrick Collision Center Birmingham

Incident Report for Hendrick Automotive Group

Resolved

Network connectivity has been restored.
Posted Aug 22, 2026 - 10:11 EDT

Identified

Our carrier has identified a power issue, at one of their facilities, as the cause of the outage. We are working with the carrier to restore connectivity.
Posted Aug 21, 2026 - 17:23 EDT

Update

We are continuing to investigate this issue.
Posted Aug 21, 2026 - 16:43 EDT

Investigating

Hendrick Collision Center Birmingham is experiencing a partial network outage. While the primary network is operational, performance may be impacted. Other services, including the Hendrick Wifi, Guest wireless networks, and other miscellaneous devices are unavailable. Our IT teams are addressing the issue, and we will provide updates as more information becomes available.
Posted Aug 21, 2026 - 16:37 EDT
This incident affected: Network Services.