Early Office Closure - HAG Management Office
Incident Report for Hendrick Automotive Group
Resolved
This incident has been resolved.
Posted Jan 10, 2025 - 21:12 EST
Investigating
Due to the potential impact a winter storm in the Charlotte area, the Hendrick Automotive Group management office will close at 12:30 PM on Friday, January 10.

Please check for updates on office status and subscribe to text alerts at http://status.hendrickauto.com/.

Thank you.
Posted Jan 09, 2025 - 20:04 EST
This incident affected: Announcements.