Power Outage - Rick Hendrick Toyota Sandy Springs
Incident Report for Hendrick Automotive Group
Resolved
Power has been restored at Rick Hendrick Toyota Sandy Springs. All systems are functioning normally.
Posted Jul 24, 2024 - 11:01 EDT
Investigating
Rick Hendrick Toyota Sandy Springs is experiencing a power outage, as a result of inclement weather in the area. The local power company has been contacted. We will provide updates as more information becomes available.
Posted Jul 23, 2024 - 19:57 EDT
This incident affected: Building Operations.