Power Outage - Southern Vehicle Accessories

Incident Report for Hendrick Automotive Group

Resolved

Power has been restored.
Posted Feb 11, 2026 - 09:19 EST

Identified

Southern Vehicle Accessories is experiencing a power outage due to a power pole replacement in the area. We will provide an update as more information becomes available.
Posted Feb 10, 2026 - 13:54 EST
This incident affected: Building Operations.