Partial Network Outage - BMW of McKinney

Incident Report for Hendrick Automotive Group

Resolved

Connectivity has been restored. All systems are functioning normally.
Posted Dec 06, 2025 - 13:47 EST

Investigating

BMW of McKinney is experiencing a partial network outage. While the primary network is operational, BMW programming and other miscellaneous services are currently unavailable. Our IT teams are troubleshooting the issue, and we will provide updates as more information becomes available.
Posted Dec 06, 2025 - 11:49 EST
This incident affected: Network Services.