Outage - Reynolds & Reynolds Support Lines
Incident Report for Hendrick Automotive Group
Resolved
Reynolds & Reynolds has resolved the issue and they are now reachable through their support lines.
Posted Apr 20, 2024 - 10:45 EDT
Investigating
Reynolds & Reynolds is experiencing an outage with their support phone numbers. This outage impacts their Technical Assistance Center, Docupad and Keytrak support lines. Reynolds & Reynolds is aware of the issue and is working diligently to resolve the issue. We will provide an update once the issue is resolved.
Posted Apr 19, 2024 - 09:24 EDT
This incident affected: Reynolds & Reynolds DMS.