Power Outage - Hendrick Lexus Charlotte
Incident Report for Hendrick Automotive Group
Resolved
Power has been restored at Hendrick Lexus Charlotte.
Posted Apr 15, 2024 - 22:33 EDT
Identified
Hendrick Lexus Charlotte is experiencing a power outage as a result of damage to a power pole in the area. Repairs are underway and power is estimated to be restored by 8:15 ET. We will provide an update as more information becomes available.
Posted Apr 15, 2024 - 18:39 EDT
This incident affected: Building Operations and Network Services.